Samba com Erro: “vfs_snapper is enabled but prerequisite dbus-1 package not found”

Problema

Ao tentar compilar o samba acontece o seguinte erro:

vfs_snapper is enabled but prerequisite dbus-1 package not found. Use --with-shared-modules=!vfs_snapper to disable vfs_snapper support.
(complete log in /home/elder/downloads/samba-4.13.3/bin/config.log)

 

Solução

E é necessário ter instalado a biblioteca “libdbus-1-dev” para não ocorrer o erro abaixo

 

Debian, Ubuntu e derivados

sudo apt install libdbus-1-dev  -y

Red Hat, CentOS, Rocky Linux, Oracle Linux e derivados

sudo yum install dbus-devel  -y

 

Deixe um comentário

O seu endereço de e-mail não será publicado.